Praxisarchiv nach Server und SQL-Umstellung extrem langsam | Forum

Hendrik Bläser

Hallo zusammen,


Bei der Server-Umstellung (T-Server 2019) wurde die neue Praxisarchiv-Version 5 und eine Umstellung auf SQL für das Praxisarchiv vorgenommen.

Nun verhält sich Praxisarchiv sehr träge, sodass ein Arbeiten damit sehr schwer fällt. Meine Tests haben ergeben, dass der Programmstart
sich schon enorm verzögert und das Programm dann irgendwann aufpoppt.

Das kannte ich damals von dem alten Praxisarchiv, wenn der Server neugestartet wurde.
Hierbei scheint es bei jedem Benutzer, bei jedem Programmstart auf dem Terminalserver zu dieser extremen Verzögerung zu kommen, als ob jedes Mal die Datenbank neu indiziert wird.

Hat jemand eine Idee?

Hendrik Bläser
Zitat von Hendrik Bläser

Hallo zusammen,


Bei der Server-Umstellung (T-Server 2019) wurde die neue Praxisarchiv-Version 5 und eine Umstellung auf SQL für das Praxisarchiv vorgenommen.

Nun verhält sich Praxisarchiv sehr träge, sodass ein Arbeiten damit sehr schwer fällt. Meine Tests haben ergeben, dass der Programmstart
sich schon enorm verzögert und das Programm dann irgendwann aufpoppt.

Das kannte ich damals von dem alten Praxisarchiv, wenn der Server neugestartet wurde.
Hierbei scheint es bei jedem Benutzer, bei jedem Programmstart auf dem Terminalserver zu dieser extremen Verzögerung zu kommen, als ob jedes Mal die Datenbank neu indiziert wird.

Hat jemand eine Idee?


Nach dem Server-Neustart läuft es super. Aber über den Tag wird es immer träger, als ob irgendein Speicher voll läuft, der sich erst beim Neustart des Server löscht. Die System-Ressourcen sind längst nicht ausgelastet. Was kann das sein?
Tobias Lietz
Tobias Lietz Aug 6

Hallo,

ich werfe mal ein paar Fragen in den Raum :)

- Läuft der PRAXISARCHIV Server und die Datenbank auf dem selben Server? 
- Handelt es sich um physikalischen Server oder virtuell (falls letzteres wie ist beim Hyper-V oder ESX die Verteilung der CPU und RAM; Anzahl vCPU, Dynamischer RAM; Gewichtung Ressourcen des vServer gemessen am gesamt Server)?
- Welche Art von Festplatten werden eingesetzt?
- Wieviele Benutzer arbeiten gleichzeitig? 
- Ist die Leistung des Terminalservers für "Programme" oder "Hintergrunddienste" optimiert?
- Ist das Verzeichnis vom Virenscanner ausgeschlossen?
- Lässt sich in der Windows Ereignisanzeige etwas erkennen?
- Gibt es irgendein Dienst unterm Task-Manager der stetig an Ressourcen zunimmt?

Je nach dem welche Version genau eingesetzt wird, könnte ggf. ein tgl. Task helfen der die Tabelle PendingJobs leert.

In dem Installationsverzeichnis vom Praxisarchiv gibt es ein Trace Ordner dort sollte eine Log-Datei liegen. Ist da etwas auffälliges zu lesen?

Vielleicht hilft es die Ansicht der Toolbar und Co. wieder auf die "alte" Ansicht zu wechseln. 

Man kann auch einstellen, wieviele Thumbnails unten in der Vorschau angeboten werden, das haben wir bei uns runtergesetzt damit lief es zügiger. 

Falls die DICOM Funktion nicht genutzt wird, kann der Task CGM PACS Dicom Master und CGM Archive Dicom Proxy deaktiviert werden.

Hendrik Bläser

Hallo,

dieses Problem ist bisher zum Glück nach einem erneuten Server-Neustart nicht wieder aufgetaucht.

Vielen Dank für Ihre Fragen und Antworten. Ich werde das natürlich weiter im Auge behalten.

Hendrik Bläser

Hallo Herr Lietz,

ich muss das Thema leider wieder aufnehmen.

Nach 4 - 5 Tagen ist dann wieder so weit, dassdas Praxisarchiv extrem langsam wird. Ich habe auch versucht die PA-Dienste neuzustarten, das hilft dann aber leider nicht. Nur ein Neustart des Servers hilft.

Dann läuft es erstmal sehr gut. Sie schrieben oben von 2 Möglichkeiten, die ich gern ausprobieren würde.

1. Leeren der Tabelle "PendingJobs"

2. Einstellung der Anzahl der "Thumbnails"

Können Sie mir dazu nährere Informationen geben?

Tobias Lietz
Tobias Lietz Aug 30
Hallo Herr Bläser, hätte die E-Mail Benachrichtigung hier im Forum funktioniert, hätte ich mich auch schon eher gemeldet ;) Es gibt eine ausführbare exe-Datei die natürlich nicht im Auslieferungszustand dabei ist welche die Tabelle mit den PendingJobs leert. Entweder Sie wenden sich an ihren VSP oder schreiben mir ihre E-Mail per PN dann lasse ich Ihnen das Programm zukommen. Zu Punkt 2 müssten Sie auf den Clients unter C:\ProgramData\CG\Archive\Configuration in die Datei settings.ini und dann müsste das der Eintrag ThumbnailLabel in der Sektion Thumbnail sein. Standard ist 15 wir haben das auf 3 heruntergesetzt. Viele Grüße